Search found 4 matches

by Sdwatt
Thu Sep 28, 2023 10:56 pm
Forum: Maintenance and Repair
Topic: What did I break?
Replies: 4
Views: 2036

What did I break?

I was trying to clean and lubricate the speed control of my (new to me) Mark V 500 and as I was cranking the speed up it popped and rattled quite a bit. I’m pretty sure the circled part in this photo should be pushed toward the right and into the shaft there. Did I break it? Do I need to replace it?...
by Sdwatt
Thu Sep 21, 2023 12:06 am
Forum: Beginning Woodworking
Topic: What am I doing wrong?
Replies: 15
Views: 7190

Re: What am I doing wrong?

The pic is pre-rotating….
by Sdwatt
Thu Sep 21, 2023 12:05 am
Forum: Beginning Woodworking
Topic: What am I doing wrong?
Replies: 15
Views: 7190

Re: What am I doing wrong?

Okay I looked at what you all said. I can’t get the arbor off the blade. I had the arbor on the spindle all the way to the left. The knurled collar set screw was caked with dust and hard to see but I cleaned it out and when I put the blade back on I’ll make sure that they line up like they’re suppos...
by Sdwatt
Tue Sep 19, 2023 3:38 pm
Forum: Beginning Woodworking
Topic: What am I doing wrong?
Replies: 15
Views: 7190

What am I doing wrong?

Hi - I’m COMPLETELY new to woodworking but I managed to get my hands on a Mark V 500. I’ve oiled and done my best to align everything, but I have a few questions. 1. I’m having trouble with the table saw setup. When I have the lower saw guard and the saw all the way on the spindle (see picture 1), I...